What’s Vulnerable › Vulnerabilities
CVE-2026-22984: libceph: prevent potential out-of-bounds reads in handle_auth_done()
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-23 · updated 2026-10-19
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: libceph: prevent potential out-of-bounds reads in handle_auth_done() Perform an explicit bounds check on payload_len to avoid a possible out-of-bounds access in the callout. [ idryomov: changelog ]
Affected products
- Linux kernel: from 5.11 before 5.15.198; from 5.16 before 6.1.161; from 6.2 before 6.6.121; from 6.7 before 6.12.66; from 6.13 before 6.18.6; 6.19-rc1, 6.19-rc2, 6.19-rc3, 6.19-rc4 — fixed in 5.15.198, 6.1.161, 6.12.66, 6.18.6, 6.6.121
How to fix
Upgrade to a fixed version: Linux kernel 5.15.198, 6.1.161, 6.12.66, 6.18.6. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/194cfe2af4d2a1de599d39dad636b47c2f6c2c96
- https://git.kernel.org/stable/c/2802ef3380fa8c4a08cda51ec1f085b1a712e9e2
- https://git.kernel.org/stable/c/2d653bb63d598ae4b096dd678744bdcc34ee89e8
- https://git.kernel.org/stable/c/79fe3511db416d2f2edcfd93569807cb02736e5e
- https://git.kernel.org/stable/c/818156caffbf55cb4d368f9c3cac64e458fb49c9
- https://git.kernel.org/stable/c/ef208ea331ef688729f64089b895ed1b49e842e3
Get alerted when CVE-2026-22984 or the next vulnerability affects your stack