What’s Vulnerable › Vulnerabilities
CVE-2026-22990: libceph: replace overzealous BUG_ON in osdmap_apply_incremental()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-23 · updated 2026-10-19
- Weakness: CWE-617
Description
In the Linux kernel, the following vulnerability has been resolved: libceph: replace overzealous BUG_ON in osdmap_apply_incremental() If the osdmap is (maliciously) corrupted such that the incremental osdmap epoch is different from what is expected, there is no need to BUG. Instead, just declare the incremental osdmap to be invalid.
Affected products
- Linux kernel: from 2.6.34.1 before 5.10.248; from 5.11 before 5.15.198; from 5.16 before 6.1.161; from 6.2 before 6.6.121; from 6.7 before 6.12.66; from 6.13 before 6.18.6 — fixed in 5.10.248, 5.15.198, 6.1.161, 6.12.66, 6.18.6, 6.6.121
How to fix
Upgrade to a fixed version: Linux kernel 5.10.248, 5.15.198, 6.1.161, 6.12.66. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4b106fbb1c7b841cd402abd83eb2447164c799ea
- https://git.kernel.org/stable/c/6348d70af847b79805374fe628d3809a63fd7df3
- https://git.kernel.org/stable/c/6afd2a4213524bc742b709599a3663aeaf77193c
- https://git.kernel.org/stable/c/6c6cec3db3b418c4fdf815731bc39e46dff75e1b
- https://git.kernel.org/stable/c/9aa0b0c14cefece078286d78b97d4c09685e372d
- https://git.kernel.org/stable/c/d3613770e2677683e65d062da5e31f48c409abe9
- https://git.kernel.org/stable/c/e00c3f71b5cf75681dbd74ee3f982a99cb690c2b
Get alerted when CVE-2026-22990 or the next vulnerability affects your stack