What’s Vulnerable › Vulnerabilities
CVE-2026-23015: gpio: mpsse: fix reference leak in gpio_mpsse_probe() error paths
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-31 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: gpio: mpsse: fix reference leak in gpio_mpsse_probe() error paths The reference obtained by calling usb_get_dev() is not released in the gpio_mpsse_probe() error paths. Fix that by using device managed helper functions. Also remove the usb_put_dev() call in the disconnect function since now it will be released automatically.
Affected products
- Linux kernel: from 6.13.1 before 6.18.6; 6.13, 6.19-rc1, 6.19-rc2, 6.19-rc3, 6.19-rc4, 6.19-rc5 (+3) — fixed in 6.18.6
How to fix
Upgrade to a fixed version: Linux kernel 6.18.6. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1e876e5a0875e71e34148c9feb2eedd3bf6b2b43
- https://git.kernel.org/stable/c/7ea26e6dcabc270433b6ded2a1aee85b215d1b28
Get alerted when CVE-2026-23015 or the next vulnerability affects your stack