What’s Vulnerable › Vulnerabilities
CVE-2026-2303: Heap Out-of-Bounds Read in Go Driver GSSAPI C Wrappers enables application crash or information leak
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-10 · updated 2026-06-17
- Weakness: CWE-183
Description
The mongo-go-driver repository contains CGo bindings for GSSAPI (Kerberos) authentication on Linux and macOS. The C wrapper implementation contains a heap out-of-bounds read vulnerability due to incorrect assumptions about string termination in the GSSAPI standard. Since GSSAPI buffers are not guaranteed to be null-terminated or have extra padding, this results in reading one byte past the allocated heap buffer.
Affected products
- MongoDB Inc MongoDB Go Driver: from 1.0.0 before 1.17.7; from 2.0.0 before 2.4.2 — fixed in 1.17.7, 2.4.2
How to fix
Upgrade to a fixed version: MongoDB Inc MongoDB Go Driver 1.17.7, 2.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-2303 or the next vulnerability affects your stack