What’s Vulnerable › Vulnerabilities
CVE-2026-23060: crypto: authencesn - reject too-short AAD (assoclen<8) to match ESP/ESN spec
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-04 · updated 2026-10-19
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: crypto: authencesn - reject too-short AAD (assoclen<8) to match ESP/ESN spec authencesn assumes an ESP/ESN-formatted AAD. When assoclen is shorter than the minimum expected length, crypto_authenc_esn_decrypt() can advance past the end of the destination scatterlist and trigger a NULL pointer dereference in scatterwalk_map_and_copy(), leading to a kernel panic (DoS). Add a minimum AAD length check to fail fast on invalid inputs.
Affected products
- Linux kernel: from 4.3 before 5.10.249; from 5.11 before 5.15.199; from 5.16 before 6.1.162; from 6.2 before 6.6.122; from 6.7 before 6.12.68; from 6.13 before 6.18.8 — fixed in 5.10.249, 5.15.199, 6.1.162, 6.12.68, 6.18.8, 6.6.122
How to fix
Upgrade to a fixed version: Linux kernel 5.10.249, 5.15.199, 6.1.162, 6.12.68. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/161bdc90fce25bd9890adc67fa1c8563a7acbf40
- https://git.kernel.org/stable/c/2397e9264676be7794f8f7f1e9763d90bd3c7335
- https://git.kernel.org/stable/c/767e8349f7e929b7dd95c08f0b4cb353459b365e
- https://git.kernel.org/stable/c/9532ff0d0e90ff78a214299f594ab9bac81defe4
- https://git.kernel.org/stable/c/b0a9609283a5c852addb513dafa655c61eebc1ef
- https://git.kernel.org/stable/c/df22c9a65e9a9daa368a72fed596af9d7d5876bb
- https://git.kernel.org/stable/c/fee86edf5803f1d1f19e3b4f2dacac241bddfa48
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html
- https://cert-portal.siemens.com/productcert/html/ssa-457936.html
Get alerted when CVE-2026-23060 or the next vulnerability affects your stack