What’s Vulnerable › Vulnerabilities
CVE-2026-23062: platform/x86: hp-bioscfg: Fix kernel panic in GET_INSTANCE_ID macro
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-04 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: platform/x86: hp-bioscfg: Fix kernel panic in GET_INSTANCE_ID macro The GET_INSTANCE_ID macro that caused a kernel panic when accessing sysfs attributes: 1. Off-by-one error: The loop condition used '<=' instead of '<', causing access beyond array bounds. Since array indices are 0-based and go from 0 to instances_count-1, the loop should use '<'. 2. Missing NULL check: The code dereferenced attr_name_kobj->name without checking if attr_name_kobj was NULL, causing a null pointer dereference in min_length_show() and other attribute show functions. The panic occurred when fwupd tried to read BIOS configuration attributes: Oops: general protection fault [#1] SMP KASAN NOPTI KASAN: null-ptr-deref in range [0x0000000000000000-0x0000000000000007] RIP: 0010:min_length_show+0xcf/0x1d0 [hp_bioscfg] Add a NULL check for attr_name_kobj before dereferencing and corrects the loop boundary to match the pattern used elsewhere in the driver.
Affected products
- Linux kernel: from 6.6 before 6.6.122; from 6.7 before 6.12.68; from 6.13 before 6.18.8; 6.19-rc1, 6.19-rc2, 6.19-rc3, 6.19-rc4, 6.19-rc5, 6.19-rc6 — fixed in 6.12.68, 6.18.8, 6.6.122
How to fix
Upgrade to a fixed version: Linux kernel 6.12.68, 6.18.8, 6.6.122. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/193922a23d7294085a47d7719fdb7d66ad0a236f
- https://git.kernel.org/stable/c/25150715e0b049b99df664daf05dab12f41c3e13
- https://git.kernel.org/stable/c/eb5ff1025c92117d5d1cc728bcfa294abe484da1
- https://git.kernel.org/stable/c/eba49c1dee9c5e514ca18e52c545bba524e8a045
Get alerted when CVE-2026-23062 or the next vulnerability affects your stack