What’s Vulnerable › Vulnerabilities
CVE-2026-23079: gpio: cdev: Fix resource leaks on errors in lineinfo_changed_notify()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-04 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: gpio: cdev: Fix resource leaks on errors in lineinfo_changed_notify() On error handling paths, lineinfo_changed_notify() doesn't free the allocated resources which results leaks. Fix it.
Affected products
- Linux kernel: from 6.17.10 before 6.18; from 6.18.1 before 6.18.8; 6.18, 6.18-rc7, 6.19-rc1, 6.19-rc2, 6.19-rc3, 6.19-rc4 (+2) — fixed in 6.18, 6.18.8
How to fix
Upgrade to a fixed version: Linux kernel 6.18, 6.18.8. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/16414341b0dd58b650b5df45c79115bc5977bb76
- https://git.kernel.org/stable/c/70b3c280533167749a8f740acaa8ef720f78f984
Get alerted when CVE-2026-23079 or the next vulnerability affects your stack