What’s Vulnerable › Vulnerabilities
CVE-2026-23118: rxrpc: Fix data-race warning and potential load/store tearing
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-14 · updated 2026-10-30
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: rxrpc: Fix data-race warning and potential load/store tearing Fix the following: BUG: KCSAN: data-race in rxrpc_peer_keepalive_worker / rxrpc_send_data_packet which is reporting an issue with the reads and writes to ->last_tx_at in: conn->peer->last_tx_at = ktime_get_seconds(); and: keepalive_at = peer->last_tx_at + RXRPC_KEEPALIVE_TIME; The lockless accesses to these to values aren't actually a problem as the read only needs an approximate time of last transmission for the purposes of deciding whether or not the transmission of a keepalive packet is warranted yet. Also, as ->last_tx_at is a 64-bit value, tearing can occur on a 32-bit arch. Fix both of these by switching to an unsigned int for ->last_tx_at and only storing the LSW of the time64_t. It can then be reconstructed at need provided no more than 68 years has elapsed since the last transmission.
Affected products
- Linux kernel: from 4.17 before 6.12.69; from 6.13 before 6.18.8; 6.19-rc1, 6.19-rc2, 6.19-rc3, 6.19-rc4, 6.19-rc5, 6.19-rc6 — fixed in 6.12.69, 6.18.8
- Linux: 4.17 — fixed in 6.19
How to fix
Upgrade to a fixed version: Linux kernel 6.12.69, 6.18.8; Linux 6.19. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/49b8ef1abfe7713e15d9128006cb76e413b12b57
- https://git.kernel.org/stable/c/5d5fe8bcd331f1e34e0943ec7c18432edfcf0e8b
- https://git.kernel.org/stable/c/a426f29ac3fa3465093567ab763ada46762fb57c
- https://git.kernel.org/stable/c/c08cf314191cd0f8699089715efb9eff030f0086
- https://git.kernel.org/stable/c/f8cf1368e0a5491b27189a695c36f64e48f3d19d
Get alerted when CVE-2026-23118 or the next vulnerability affects your stack