What’s Vulnerable › Vulnerabilities
CVE-2026-23149: drm: Do not allow userspace to trigger kernel warnings in drm_gem_change_handle_ioctl()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-14 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: drm: Do not allow userspace to trigger kernel warnings in drm_gem_change_handle_ioctl() Since GEM bo handles are u32 in the uapi and the internal implementation uses idr_alloc() which uses int ranges, passing a new handle larger than INT_MAX trivially triggers a kernel warning: idr_alloc(): ... if (WARN_ON_ONCE(start < 0)) return -EINVAL; ... Fix it by rejecting new handles above INT_MAX and at the same time make the end limit calculation more obvious by moving into int domain.
Affected products
- Linux kernel: from 6.18 before 6.18.9; 6.19-rc1, 6.19-rc2, 6.19-rc3, 6.19-rc4, 6.19-rc5, 6.19-rc6 (+1) — fixed in 6.18.9
How to fix
Upgrade to a fixed version: Linux kernel 6.18.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/12f15d52d38ac53f7c70ea3d4b3d76afed04e064
- https://git.kernel.org/stable/c/ae8831ee0fb2f5f41f39722e7b3749d65bb78d08
Get alerted when CVE-2026-23149 or the next vulnerability affects your stack