What’s Vulnerable › Vulnerabilities
CVE-2026-23191: ALSA: aloop: Fix racy access at PCM trigger
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-14 · updated 2026-10-19
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: ALSA: aloop: Fix racy access at PCM trigger The PCM trigger callback of aloop driver tries to check the PCM state and stop the stream of the tied substream in the corresponding cable. Since both check and stop operations are performed outside the cable lock, this may result in UAF when a program attempts to trigger frequently while opening/closing the tied stream, as spotted by fuzzers. For addressing the UAF, this patch changes two things: - It covers the most of code in loopback_check_format() with cable->lock spinlock, and add the proper NULL checks. This avoids already some racy accesses. - In addition, now we try to check the state of the capture PCM stream that may be stopped in this function, which was the major pain point leading to UAF.
Affected products
- Linux kernel: from 2.6.37 before 6.12.70; from 6.13 before 6.18.10; 6.19-rc1, 6.19-rc2, 6.19-rc3, 6.19-rc4, 6.19-rc5, 6.19-rc6 (+2) — fixed in 6.12.70, 6.18.10
How to fix
Upgrade to a fixed version: Linux kernel 6.12.70, 6.18.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0e6245b2424d126ac90018142d09f0707e12998b
- https://git.kernel.org/stable/c/5727ccf9d19ca414cb76d9b647883822e2789c2e
- https://git.kernel.org/stable/c/826af7fa62e347464b1b4e0ba2fe19a92438084f
- https://git.kernel.org/stable/c/bad15420050db1803767e58756114800cce91ea4
- https://git.kernel.org/stable/c/c99be0d5af02adebe9cb6f9869d20397fa9935a3
- https://git.kernel.org/stable/c/f3ce8be893726899e3053cf8059ecc95d8410359
- https://git.kernel.org/stable/c/f57467114f40c5aacebbea96fb4ff9e5cd2b7f18
Get alerted when CVE-2026-23191 or the next vulnerability affects your stack