What’s Vulnerable › Vulnerabilities
CVE-2026-23208: ALSA: usb-audio: Prevent excessive number of frames
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-14 · updated 2026-10-30
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: ALSA: usb-audio: Prevent excessive number of frames In this case, the user constructed the parameters with maxpacksize 40 for rate 22050 / pps 1000, and packsize[0] 22 packsize[1] 23. The buffer size for each data URB is maxpacksize * packets, which in this example is 40 * 6 = 240; When the user performs a write operation to send audio data into the ALSA PCM playback stream, the calculated number of frames is packsize[0] * packets = 264, which exceeds the allocated URB buffer size, triggering the out-of-bounds (OOB) issue reported by syzbot [1]. Added a check for the number of single data URB frames when calculating the number of frames to prevent [1]. [1] BUG: KASAN: slab-out-of-bounds in copy_to_urb+0x261/0x460 sound/usb/pcm.c:1487 Write of size 264 at addr ffff88804337e800 by task syz.0.17/5506 Call Trace: copy_to_urb+0x261/0x460 sound/usb/pcm.c:1487 prepare_playback_urb+0x953/0x13d0 sound/usb/pcm.c:1611 prepare_outbound_urb+0x377/0xc50 sound/usb/endpoint.c:333
Affected products
- Linux kernel: from 4.14.186 before 4.14.188; from 4.19.130 before 4.19.132; from 5.4.49 before 5.4.51; from 5.7.6 before 5.7.8; from 5.8 before 6.18.10; 6.19-rc1, 6.19-rc2, 6.19-rc3, 6.19-rc4, 6.19-rc5 — fixed in 4.14.188, 4.19.132, 5.4.51, 5.7.8, 6.18.10
- Linux: from 4.4.229 before 4.4.230; from 4.9.229 before 4.9.230; from 4.14.186 before 4.14.188; from 4.19.130 before 4.19.132; from 5.4.49 before 5.4.51; from 5.7.6 before 5.7.8 — fixed in 4.4.230, 4.9.230, 4.14.188, 4.19.132, 5.4.51, 5.7.8
How to fix
Upgrade to a fixed version: Linux kernel 4.14.188, 4.19.132, 5.4.51, 5.7.8; Linux 4.4.230, 4.9.230, 4.14.188, 4.19.132. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/152fc4f7b4a8af1c0418d2722f3b2729799cc837
- https://git.kernel.org/stable/c/282aba56713bbc58155716b55ca7222b2d9cf3c8
- https://git.kernel.org/stable/c/480a1490c595a242f27493a4544b3efb21b29f6a
- https://git.kernel.org/stable/c/581821f4b2ecbf411027b0af82b561ee208f4ba4
- https://git.kernel.org/stable/c/62932d9ed639a9fa71b4ac1a56766a4b43abb7e4
- https://git.kernel.org/stable/c/81e4b0009f2acc841d77a24fd796528b0bf62c4e
- https://git.kernel.org/stable/c/ab0b5e92fc36ee82c1bd01fe896d0f775ed5de41
- https://git.kernel.org/stable/c/c4dc012b027c9eb101583011089dea14d744e314
- https://git.kernel.org/stable/c/d67dde02049e632ba58d3c44a164a74b6a737154
- https://git.kernel.org/stable/c/e0ed5a36fb3ab9e7b9ee45cd17f09f6d5f594360
- https://git.kernel.org/stable/c/ef5749ef8b307bf8717945701b1b79d036af0a15
Get alerted when CVE-2026-23208 or the next vulnerability affects your stack