What’s Vulnerable › Vulnerabilities
CVE-2026-23221: bus: fsl-mc: fix use-after-free in driver_override_show()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-18 · updated 2026-06-17
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: bus: fsl-mc: fix use-after-free in driver_override_show() The driver_override_show() function reads the driver_override string without holding the device_lock. However, driver_override_store() uses driver_set_override(), which modifies and frees the string while holding the device_lock. This can result in a concurrent use-after-free if the string is freed by the store function while being read by the show function. Fix this by holding the device_lock around the read operation.
Affected products
- Linux kernel: from 5.10 before 5.15.201; from 5.16 before 6.1.164; from 6.2 before 6.6.127; from 6.7 before 6.12.74; from 6.13 before 6.18.11; from 6.19 before 6.19.1 — fixed in 5.15.201, 6.1.164, 6.12.74, 6.18.11, 6.19.1, 6.6.127
How to fix
Upgrade to a fixed version: Linux kernel 5.15.201, 6.1.164, 6.12.74, 6.18.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/148891e95014b5dc5878acefa57f1940c281c431
- https://git.kernel.org/stable/c/1d6bd6183e723a7b256ff34bbb5b498b5f4f2ec0
- https://git.kernel.org/stable/c/a2ae33e1c6361e960a4d00f7cf75d880b54f9528
- https://git.kernel.org/stable/c/b1983840287303e0dfb401b1b6cecc5ea7471e90
- https://git.kernel.org/stable/c/c424e72cfa67e7e1477035058a8a659f2c0ea637
- https://git.kernel.org/stable/c/c71dfb7833db7af652ee8f65011f14c97c47405d
- https://git.kernel.org/stable/c/dd8ba8c0c3f3916d4ee1e3a09da9cd5caff5d227
Get alerted when CVE-2026-23221 or the next vulnerability affects your stack