What’s Vulnerable › Vulnerabilities
CVE-2026-23245: net/sched: act_gate: snapshot parameters with RCU on replace
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-18 · updated 2026-10-15
Description
In the Linux kernel, the following vulnerability has been resolved: net/sched: act_gate: snapshot parameters with RCU on replace The gate action can be replaced while the hrtimer callback or dump path is walking the schedule list. Convert the parameters to an RCU-protected snapshot and swap updates under tcf_lock, freeing the previous snapshot via call_rcu(). When REPLACE omits the entry list, preserve the existing schedule so the effective state is unchanged.
Affected products
- Linux kernel: from 5.8.1 before 5.10.253; from 5.11 before 6.1.167; from 6.2 before 6.6.130; from 6.7 before 6.12.78; from 6.13 before 6.18.18; from 6.19 before 6.19.8 — fixed in 5.10.253, 6.1.167, 6.12.78, 6.18.18, 6.19.8, 6.6.130
How to fix
Upgrade to a fixed version: Linux kernel 5.10.253, 6.1.167, 6.12.78, 6.18.18. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/035d0d09d5ab3ed3e93d18cde2b562a6719eea23
- https://git.kernel.org/stable/c/04d75529dc0f9be78786162ebab7424af4644df2
- https://git.kernel.org/stable/c/58b162e318d0243ad2d7d92456c0873f2494c351
- https://git.kernel.org/stable/c/62413a9c3cb183afb9bb6e94dd68caf4e4145f4c
- https://git.kernel.org/stable/c/8b1251bbf0f10ac745ed74bad4d3b433caa1eeae
- https://git.kernel.org/stable/c/dfc314d7c767e350f78a46a8f8b134f80e8ad432
- https://git.kernel.org/stable/c/fc98fd8d214693be91253d9a88cdf8e5e143d124
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html
- https://cert-portal.siemens.com/productcert/html/ssa-082556.html
- https://cert-portal.siemens.com/productcert/html/ssa-457936.html
- https://cert-portal.siemens.com/productcert/html/ssa-784472.html
Get alerted when CVE-2026-23245 or the next vulnerability affects your stack