What’s Vulnerable › Vulnerabilities
CVE-2026-23251: xfs: only call xf{array,blob}_destroy if we have a valid pointer
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-18 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: xfs: only call xf{array,blob}_destroy if we have a valid pointer Only call the xfarray and xfblob destructor if we have a valid pointer, and be sure to null out that pointer afterwards. Note that this patch fixes a large number of commits, most of which were merged between 6.9 and 6.10.
Affected products
- Linux kernel: from 6.10 before 6.12.75; from 6.13 before 6.18.16; from 6.19 before 6.19.6 — fixed in 6.12.75, 6.18.16, 6.19.6
How to fix
Upgrade to a fixed version: Linux kernel 6.12.75, 6.18.16, 6.19.6. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/5de5be3ed7e7fa4ebde4f4b58fb9a629644f9202
- https://git.kernel.org/stable/c/ba408d299a3bb3c5309f40c5326e4fb83ead4247
- https://git.kernel.org/stable/c/c9ccefacae0d8091683447bc338bd7741417039d
- https://git.kernel.org/stable/c/d827612c81a26cc1dd83a211cfcb5ad8765da0c4
Get alerted when CVE-2026-23251 or the next vulnerability affects your stack