What’s Vulnerable › Vulnerabilities
CVE-2026-2327
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-12 · updated 2026-06-17
- Weakness: CWE-1333
Description
Versions of the package markdown-it from 13.0.0 and before 14.1.1 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the use of the regex /\*+$/ in the linkify function. An attacker can supply a long sequence of * characters followed by a non-matching character, which triggers excessive backtracking and may lead to a denial-of-service condition.
Affected products
- markdown-it: from 13.0.0 before 14.1.1 — fixed in 14.1.1
How to fix
Upgrade to a fixed version: markdown-it 14.1.1. Check the vendor advisory for mitigations.
References
- https://gist.github.com/ltduc147/c9abecae1b291ede4f692f2ab988c917
- https://github.com/markdown-it/markdown-it/blob/14.1.0/lib/rules_inline/linkify.mjs%23L33
- https://github.com/markdown-it/markdown-it/commit/4b4bbcae5e0990a5b172378e507b33a59012ed26
- https://security.snyk.io/vuln/SNYK-JS-MARKDOWNIT-10666750
- https://gist.github.com/ltduc147/c9abecae1b291ede4f692f2ab988c917
- https://security.snyk.io/vuln/SNYK-JS-MARKDOWNIT-10666750
Get alerted when CVE-2026-2327 or the next vulnerability affects your stack