What’s Vulnerable › Vulnerabilities
CVE-2026-2328: Backend Access Due to Insufficient Input Validation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-30 · updated 2026-06-17
- Weakness: CWE-790
Description
An unauthenticated remote attacker can exploit insufficient input validation to access backend components beyond their intended scope via path traversal, resulting in exposure of sensitive information.
Affected products
- WAGO Device Sphere: before 1.2.2 — fixed in 1.2.2
- WAGO Solution Builder: before 2.4.2 — fixed in 2.4.2
How to fix
Upgrade to a fixed version: WAGO Device Sphere 1.2.2; WAGO Solution Builder 2.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-2328 or the next vulnerability affects your stack