What’s Vulnerable › Vulnerabilities
CVE-2026-23307: can: ems_usb: ems_usb_read_bulk_callback(): check the proper length of a message
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-25 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: can: ems_usb: ems_usb_read_bulk_callback(): check the proper length of a message When looking at the data in a USB urb, the actual_length is the size of the buffer passed to the driver, not the transfer_buffer_length which is set by the driver as the max size of the buffer. When parsing the messages in ems_usb_read_bulk_callback() properly check the size both at the beginning of parsing the message to make sure it is big enough for the expected structure, and at the end of the message to make sure we don't overflow past the end of the buffer for the next message.
Affected products
- Linux kernel: from 2.6.32 before 5.10.253; from 5.11 before 5.15.203; from 5.16 before 6.1.167; from 6.2 before 6.6.130; from 6.7 before 6.12.77; from 6.13 before 6.18.17 — fixed in 5.10.253, 5.15.203, 6.1.167, 6.12.77, 6.18.17, 6.19.7
How to fix
Upgrade to a fixed version: Linux kernel 5.10.253, 5.15.203, 6.1.167, 6.12.77. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1818974e1b5ef200e27f144c8cb8a246420bb54d
- https://git.kernel.org/stable/c/18f75b9cbdc3703f15965425ab69dee509b07785
- https://git.kernel.org/stable/c/1cf469026d4a2308eaa91d04dca4a900d07a5c2e
- https://git.kernel.org/stable/c/2833e13e2b099546abf5d40a483b4eb04ddd1f7b
- https://git.kernel.org/stable/c/38a01c9700b0dcafe97dfa9dc7531bf4a245deff
- https://git.kernel.org/stable/c/aed172a2e2330131f0977d2acd3ec8883f413ec1
- https://git.kernel.org/stable/c/c703bbf8e9b4947e111c88d2ed09236a6772a471
- https://git.kernel.org/stable/c/f10177e6c4575aedaea580ce67d792fab7a2235e
Get alerted when CVE-2026-23307 or the next vulnerability affects your stack