What’s Vulnerable › Vulnerabilities
CVE-2026-2332: HTTP Request Smuggling via Chunked Extension Quoted-String Parsing
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-14 · updated 2026-10-26
- Weakness: CWE-444
Description
In Eclipse Jetty, the HTTP/1.1 parser is vulnerable to request smuggling when chunk extensions are used, similar to the "funky chunks" techniques outlined here: * https://w4ke.info/2025/06/18/funky-chunks.html * https://w4ke.info/2025/10/29/funky-chunks-2.html Jetty terminates chunk extension parsing at \r\n inside quoted strings instead of treating this as an error. POST / HTTP/1.1 Host: localhost Transfer-Encoding: chunked 1;ext="val X 0 GET /smuggled HTTP/1.1 ... Note how the chunk extension does not close the double quotes, and it is able to inject a smuggled request.
Affected products
- The Eclipse Foundation Eclipse Jetty: from 9.4.0 before 9.4.60; from 10.0.0 before 10.0.28; from 11.0.0 before 11.0.28; from 12.0.0 before 12.0.33; from 12.1.0 before 12.1.7 — fixed in 9.4.60, 10.0.28, 11.0.28, 12.0.33, 12.1.7
How to fix
Upgrade to a fixed version: The Eclipse Foundation Eclipse Jetty 9.4.60, 10.0.28, 11.0.28, 12.0.33. Check the vendor advisory for mitigations.
References
- https://github.com/jetty/jetty.project/security/advisories/GHSA-355h-qmc2-wpwf
- https://gitlab.eclipse.org/security/cve-assignment/-/issues/89
- https://access.redhat.com/errata/RHSA-2026:10175
- https://access.redhat.com/errata/RHSA-2026:14272
- https://access.redhat.com/errata/RHSA-2026:17668
- https://access.redhat.com/errata/RHSA-2026:20568
- https://access.redhat.com/errata/RHSA-2026:21773
- https://access.redhat.com/errata/RHSA-2026:22453
- https://access.redhat.com/errata/RHSA-2026:25089
- https://access.redhat.com/errata/RHSA-2026:50221
- https://access.redhat.com/errata/RHSA-2026:50222
- https://access.redhat.com/errata/RHSA-2026:50223
Get alerted when CVE-2026-2332 or the next vulnerability affects your stack