What’s Vulnerable › Vulnerabilities
CVE-2026-23330: nfc: nci: complete pending data exchange on device close
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-25 · updated 2026-10-30
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: nfc: nci: complete pending data exchange on device close In nci_close_device(), complete any pending data exchange before closing. The data exchange callback (e.g. rawsock_data_exchange_complete) holds a socket reference. NIPA occasionally hits this leak: unreferenced object 0xff1100000f435000 (size 2048): comm "nci_dev", pid 3954, jiffies 4295441245 hex dump (first 32 bytes): 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................ 27 00 01 40 00 00 00 00 00 00 00 00 00 00 00 00 '..@............ backtrace (crc ec2b3c5): __kmalloc_noprof+0x4db/0x730 sk_prot_alloc.isra.0+0xe4/0x1d0 sk_alloc+0x36/0x760 rawsock_create+0xd1/0x540 nfc_sock_create+0x11f/0x280 __sock_create+0x22d/0x630 __sys_socket+0x115/0x1d0 __x64_sys_socket+0x72/0xd0 do_syscall_64+0x117/0xfc0 entry_SYSCALL_64_after_hwframe+0x4b/0x53
Affected products
- Linux kernel: from 3.2.1 before 6.12.82; from 6.13 before 6.18.17; from 6.19 before 6.19.7; 7.0-rc1, 7.0-rc2, 7.0-rc3, 7.0-rc4, 7.0-rc5, 7.0-rc6 (+1); 3.2 — fixed in 6.12.82, 6.18.17, 6.19.7
- Linux: 3.2 — fixed in 7.0
How to fix
Upgrade to a fixed version: Linux kernel 6.12.82, 6.18.17, 6.19.7; Linux 7.0. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/66083581945bd5b8e99fe49b5aeb83d03f62d053
- https://git.kernel.org/stable/c/702029337b057085ea13f964822dcd95e0fe53f5
- https://git.kernel.org/stable/c/75fdb22ef0635c02337de0c08c98f93f37b5cbee
- https://git.kernel.org/stable/c/91ff0d8c3464da7f0c43da38c195e60b660128bf
- https://git.kernel.org/stable/c/9df613ef6e8e873cdab969a11f74823488977f1f
- https://git.kernel.org/stable/c/d05f55d68ebdebb2b0a8480d766eaae88c8c92de
Get alerted when CVE-2026-23330 or the next vulnerability affects your stack