What’s Vulnerable › Vulnerabilities
CVE-2026-23334: can: usb: f81604: handle short interrupt urb messages properly
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-25 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: can: usb: f81604: handle short interrupt urb messages properly If an interrupt urb is received that is not the correct length, properly detect it and don't attempt to treat the data as valid.
Affected products
- Linux kernel: from 6.5.1 before 6.6.130; from 6.7 before 6.12.77; from 6.13 before 6.18.17; from 6.19 before 6.19.7; 6.5, 7.0-rc1, 7.0-rc2, 7.0-rc3, 7.0-rc4, 7.0-rc5 (+2) — fixed in 6.12.77, 6.18.17, 6.19.7, 6.6.130
How to fix
Upgrade to a fixed version: Linux kernel 6.12.77, 6.18.17, 6.19.7, 6.6.130. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/36ead57443146e6b730ce1f48ca3e9b17e19a3d2
- https://git.kernel.org/stable/c/66615e6293388f75a56226d1216fd9cfb3d95e05
- https://git.kernel.org/stable/c/7299b1b39a255f6092ce4ec0b65f66e9d6a357af
- https://git.kernel.org/stable/c/9b740ff5bc649575a5e14ca8ee54e3dd5010aaf0
- https://git.kernel.org/stable/c/c5d69da6c919648838734097861e979677eedcde
Get alerted when CVE-2026-23334 or the next vulnerability affects your stack