What’s Vulnerable › Vulnerabilities
CVE-2026-23405: apparmor: fix: limit the number of levels of policy namespaces
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-01 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: apparmor: fix: limit the number of levels of policy namespaces Currently the number of policy namespaces is not bounded relying on the user namespace limit. However policy namespaces aren't strictly tied to user namespaces and it is possible to create them and nest them arbitrarily deep which can be used to exhaust system resource. Hard cap policy namespaces to the same depth as user namespaces.
Affected products
- Linux kernel: from 2.6.36.1 before 5.10.253; from 5.11 before 5.15.203; from 5.16 before 6.1.169; from 6.2 before 6.6.130; from 6.7 before 6.12.77; from 6.13 before 6.18.18 — fixed in 5.10.253, 5.15.203, 6.1.169, 6.12.77, 6.18.18, 6.19.8
How to fix
Upgrade to a fixed version: Linux kernel 5.10.253, 5.15.203, 6.1.169, 6.12.77. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/306039414932c80f8420695a24d4fe10c84ccfb2
- https://git.kernel.org/stable/c/3f8699b3ee0c04b4b9bc27b82cd89a40e81e1d2e
- https://git.kernel.org/stable/c/6b396cc2f0365e684fc1d3547d18ef79fcee225d
- https://git.kernel.org/stable/c/7b6495ead2c611647f6b11441a852324e3eb8616
- https://git.kernel.org/stable/c/853ce31ca72097d23991a06876a2ccb5cb64b603
- https://git.kernel.org/stable/c/87d0cecc900e55d55fc4dbfb43ac93e269c7a5b3
- https://git.kernel.org/stable/c/b1226e37eb3754d389721c135db6107db94c7a72
- https://git.kernel.org/stable/c/d42b2b6bb77ca40ee34ab74ad79305840b5f315d
Get alerted when CVE-2026-23405 or the next vulnerability affects your stack