What’s Vulnerable › Vulnerabilities
CVE-2026-23413: clsact: Fix use-after-free in init/destroy rollback asymmetry
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-02 · updated 2026-10-19
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: clsact: Fix use-after-free in init/destroy rollback asymmetry Fix a use-after-free in the clsact qdisc upon init/destroy rollback asymmetry. The latter is achieved by first fully initializing a clsact instance, and then in a second step having a replacement failure for the new clsact qdisc instance. clsact_init() initializes ingress first and then takes care of the egress part. This can fail midway, for example, via tcf_block_get_ext(). Upon failure, the kernel will trigger the clsact_destroy() callback. Commit 1cb6f0bae504 ("bpf: Fix too early release of tcx_entry") details the way how the transition is happening. If tcf_block_get_ext on the q->ingress_block ends up failing, we took the tcx_miniq_inc reference count on the ingress side, but not yet on the egress side. clsact_destroy() tests whether the {ingress,egress}_entry was non-NULL. However, even in midway failure on the replacement, both are in fact non-NULL with a valid egress_entry from the previous clsact instance. What we really need to test for is whether the qdisc instance-specific ingress or egress side previously got initialized. This adds a small helper for checking the miniq initialization called mini_qdisc_pair_inited, and utilizes that upon clsact_destroy() in order to fix the use-after-free scenario. Convert the ingress_destroy() side as well so both are consistent to each other.
Affected products
- Linux kernel: from 6.6.41 before 6.6.130; from 6.9.10 before 6.10; from 6.10.1 before 6.12.78; from 6.13 before 6.18.20; from 6.19 before 6.19.10; 6.10, 7.0-rc1, 7.0-rc2, 7.0-rc3, 7.0-rc4, 7.0-rc5 (+2) — fixed in 6.10, 6.12.78, 6.18.20, 6.19.10, 6.6.130
How to fix
Upgrade to a fixed version: Linux kernel 6.10, 6.12.78, 6.18.20, 6.19.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0509b762bc5e8ea7b8391130730c6d8502fc6e69
- https://git.kernel.org/stable/c/37bef86e5428d59f70a4da82b80f9a8f252fecbe
- https://git.kernel.org/stable/c/4c9af67f99aa3e51b522c54968ab3ac8272be41c
- https://git.kernel.org/stable/c/a0671125d4f55e1e98d9bde8a0b671941987e208
- https://git.kernel.org/stable/c/a73d95b57bf9faebdfed591bcb7ed9292062a84c
Get alerted when CVE-2026-23413 or the next vulnerability affects your stack