What’s Vulnerable › Vulnerabilities
CVE-2026-23422: dpaa2-switch: Fix interrupt storm after receiving bad if_id in IRQ handler
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-03 · updated 2026-10-15
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: dpaa2-switch: Fix interrupt storm after receiving bad if_id in IRQ handler Commit 31a7a0bbeb00 ("dpaa2-switch: add bounds check for if_id in IRQ handler") introduces a range check for if_id to avoid an out-of-bounds access. If an out-of-bounds if_id is detected, the interrupt status is not cleared. This may result in an interrupt storm. Clear the interrupt status after detecting an out-of-bounds if_id to avoid the problem. Found by an experimental AI code review agent at Google.
Affected products
- Linux kernel: from 5.15.200 before 5.15.203; from 6.1.163 before 6.1.167; from 6.6.124 before 6.6.130; from 6.12.70 before 6.12.77; from 6.18.10 before 6.18.17; from 6.19.1 before 6.19.7 — fixed in 5.15.203, 6.1.167, 6.12.77, 6.18.17, 6.19.7, 6.6.130
How to fix
Upgrade to a fixed version: Linux kernel 5.15.203, 6.1.167, 6.12.77, 6.18.17. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/00f42ace446f1e4bf84988f2281131f52cd32796
- https://git.kernel.org/stable/c/28fd8ac1d49389cb230d712116f54e27ebec11b8
- https://git.kernel.org/stable/c/74badb9c20b1a9c02a95c735c6d3cd6121679c93
- https://git.kernel.org/stable/c/7def51cb9fb8b8d5342443372b8cf28d8fbd7f3d
- https://git.kernel.org/stable/c/b5bababe7703a7322bc59b803ab1587887a2a5e4
- https://git.kernel.org/stable/c/c7becfe3e604d138bd53b8ac3111b2b3e8ec6b0e
- https://git.kernel.org/stable/c/fa4412cdc5178a48799bafcb8af28fd2fbf3d703
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html
- https://cert-portal.siemens.com/productcert/html/ssa-082556.html
- https://cert-portal.siemens.com/productcert/html/ssa-457936.html
Get alerted when CVE-2026-23422 or the next vulnerability affects your stack