What’s Vulnerable › Vulnerabilities
CVE-2026-23468: drm/amdgpu: Limit BO list entry count to prevent resource exhaustion
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-03 · updated 2026-07-24
- Weakness: CWE-770
Description
In the Linux kernel, the following vulnerability has been resolved: drm/amdgpu: Limit BO list entry count to prevent resource exhaustion Userspace can pass an arbitrary number of BO list entries via the bo_number field. Although the previous multiplication overflow check prevents out-of-bounds allocation, a large number of entries could still cause excessive memory allocation (up to potentially gigabytes) and unnecessarily long list processing times. Introduce a hard limit of 128k entries per BO list, which is more than sufficient for any realistic use case (e.g., a single list containing all buffers in a large scene). This prevents memory exhaustion attacks and ensures predictable performance. Return -EINVAL if the requested entry count exceeds the limit (cherry picked from commit 688b87d39e0aa8135105b40dc167d74b5ada5332)
Affected products
- Linux kernel: from 4.2 before 6.6.140; from 6.7 before 6.12.86; from 6.13 before 6.18.20; from 6.19 before 6.19.10; 7.0-rc1, 7.0-rc2, 7.0-rc3, 7.0-rc4 — fixed in 6.12.86, 6.18.20, 6.19.10, 6.6.140
How to fix
Upgrade to a fixed version: Linux kernel 6.12.86, 6.18.20, 6.19.10, 6.6.140. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2723e6851309531ce61aed74e93a0cd268cc862a
- https://git.kernel.org/stable/c/5ce4a38e6c2488949e373d5066303f9c128db614
- https://git.kernel.org/stable/c/6270b1a5dab94665d7adce3dc78bc9066ed28bdd
- https://git.kernel.org/stable/c/c833d6c7199c5b5fca9ec95593acd539ec9c171c
- https://git.kernel.org/stable/c/e620378aab78d415bd8a15a2f91c145906520288
- https://git.kernel.org/stable/c/f462624a6e4b5f1ec2664c2c53e408b2f4fb53e9
Get alerted when CVE-2026-23468 or the next vulnerability affects your stack