What’s Vulnerable › Vulnerabilities
CVE-2026-2348: Quick Edit - Moderately critical - Cross-site Scripting - SA-CONTRIB-2026-009
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-25 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Quick Edit allows Cross-Site Scripting (XSS).This issue affects Quick Edit: from 0.0.0 before 1.0.5, from 2.0.0 before 2.0.1.
Affected products
- Drupal Quick Edit: before 1.0.5; 2.0.0 — fixed in 1.0.5
How to fix
Upgrade to a fixed version: Drupal Quick Edit 1.0.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-2348 or the next vulnerability affects your stack