What’s Vulnerable › Vulnerabilities
CVE-2026-23480: Blinko: Low Privilege User Privilege Escalation - upsertUser Endpoint
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-23 · updated 2026-06-17
- Weakness: CWE-288
Description
Blinko is an AI-powered card note-taking project. Prior to version 1.8.4, there is a privilege escalation vulnerability. The upsertUser endpoint has 3 issues: it is missing superAdminAuthMiddleware, any logged-in user can call it; the originalPassword is an optional parameter and if not provided password verification is skipped; there is no check for input.id === ctx.id (ownership verification). This could result in any authenticated user modifying other users' passwords, direct escalation to superadmin, and complete account takeover. This issue has been patched in version 1.8.4.
Affected products
- blinkospace blinko: before 1.8.4 — fixed in 1.8.4
How to fix
Upgrade to a fixed version: blinkospace blinko 1.8.4. Check the vendor advisory for mitigations.
References
- https://github.com/blinkospace/blinko/commit/3afbdf486b6f371bdac5781dea6289749f2c4c03
- https://github.com/blinkospace/blinko/releases/tag/1.8.4
- https://github.com/blinkospace/blinko/security/advisories/GHSA-r3mv-q7ww-86p6
Get alerted when CVE-2026-23480 or the next vulnerability affects your stack