What’s Vulnerable › Vulnerabilities
CVE-2026-23498: Shopware Improper Control of Generation of Code in Twig rendered views
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-14 · updated 2026-06-17
- Weakness: CWE-94
Description
Shopware is an open commerce platform. From 6.7.0.0 to before 6.7.6.1, a regression of CVE-2023-2017 leads to an array and array crafted PHP Closure not checked being against allow list for the map(...) override. This vulnerability is fixed in 6.7.6.1.
Affected products
- shopware: from 6.7.0.0 before 6.7.6.1 — fixed in 6.7.6.1
How to fix
Upgrade to a fixed version: shopware 6.7.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/shopware/shopware/commit/3966b05590e29432b8485ba47b4fcd14dd0b8475
- https://github.com/shopware/shopware/security/advisories/GHSA-7cw6-7h3h-v8pf
Get alerted when CVE-2026-23498 or the next vulnerability affects your stack