What’s Vulnerable › Vulnerabilities
CVE-2026-23517: Fleet has an Access Control vulnerability in debug/pprof endpoints
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-21 · updated 2026-06-17
- Weakness: CWE-862
Description
Fleet is open source device management software. A broken access control issue in versions prior to 4.78.3, 4.77.1, 4.76.2, 4.75.2, and 4.53.3 allowed authenticated users to access debug and profiling endpoints regardless of role. As a result, low-privilege users could view internal server diagnostics and trigger resource-intensive profiling operations. Fleet’s debug/pprof endpoints are accessible to any authenticated user regardless of role, including the lowest-privilege “Observer” role. This allows low-privilege users to access sensitive server internals, including runtime profiling data and in-memory application state, and to trigger CPU-intensive profiling operations that could lead to denial of service. Versions 4.78.3, 4.77.1, 4.76.2, 4.75.2, and 4.53.3 fix the issue. If an immediate upgrade is not possible, users should put the debug/pprof endpoints behind an IP allowlist as a workaround.
Affected products
- fleetdm fleet: before 4.53.3; from 4.75.0 before 4.75.2; from 4.76.0 before 4.76.2; from 4.78.0 before 4.78.3; 4.77.0 — fixed in 4.53.3, 4.75.2, 4.76.2, 4.78.3
How to fix
Upgrade to a fixed version: fleetdm fleet 4.53.3, 4.75.2, 4.76.2, 4.78.3. Check the vendor advisory for mitigations.
References
- https://github.com/fleetdm/fleet/commit/5c030e32a3a9bc512355b5e1bf19636e4e6d0317
- https://github.com/fleetdm/fleet/security/advisories/GHSA-4r5r-ccr6-q6f6
Get alerted when CVE-2026-23517 or the next vulnerability affects your stack