What’s Vulnerable › Vulnerabilities
CVE-2026-23535: wlc Path traversal: Unsanitized API slugs in download command
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-16 · updated 2026-06-17
- Weakness: CWE-22
Description
wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.2, the multi-translation download could write to an arbitrary location when instructed by a crafted server. This vulnerability is fixed in 1.17.2.
Affected products
- WeblateOrg wlc: before 1.17.2 — fixed in 1.17.2
How to fix
Upgrade to a fixed version: WeblateOrg wlc 1.17.2. Check the vendor advisory for mitigations.
References
- https://github.com/WeblateOrg/wlc/commit/216e691c6e50abae97fe2e4e4f21501bf49a585f
- https://github.com/WeblateOrg/wlc/pull/1128
- https://github.com/WeblateOrg/wlc/releases/tag/1.17.2
- https://github.com/WeblateOrg/wlc/security/advisories/GHSA-mmwx-79f6-67jg
Get alerted when CVE-2026-23535 or the next vulnerability affects your stack