What’s Vulnerable › Vulnerabilities
CVE-2026-2359: Multer vulnerable to Denial of Service via resource exhaustion
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-27 · updated 2026-07-15
- Weakness: CWE-772
Description
Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability in Multer prior to version 2.1.0 allows an attacker to trigger a Denial of Service (DoS) by dropping connection during file upload, potentially causing resource exhaustion. Users should upgrade to version 2.1.0 to receive a patch. No known workarounds are available.
Affected products
- multer: before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: multer 2.1.0. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/expressjs/multer/commit/cccf0fe0e64150c4f42ccf6654165c0d66b9adab
- https://github.com/expressjs/multer/security/advisories/GHSA-v52c-386h-88mc
- https://www.cve.org/CVERecord?id=CVE-2026-2359
- https://access.redhat.com/errata/RHSA-2026:6174
- https://access.redhat.com/errata/RHSA-2026:6802
- https://access.redhat.com/security/cve/CVE-2026-2359
- https://bugzilla.redhat.com/show_bug.cgi?id=2443350
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-2359.json
Get alerted when CVE-2026-2359 or the next vulnerability affects your stack