What’s Vulnerable › Vulnerabilities
CVE-2026-2360: Improper search_path protection in PostgreSQL Anonymizer 2.5 allows any user to gain superuser privileges in PostgreSQL 14
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-11 · updated 2026-06-17
- Weakness: CWE-427
Description
PostgreSQL Anonymizer contains a vulnerability that allows a user to gain superuser privileges by creating a custom operator in the public schema and place malicious code in that operator. This operator will later be executed with superuser privileges when the extension is created. The risk is higher with PostgreSQL 14 or with instances upgraded from PostgreSQL 14 or a prior version. With PostgreSQL 15 and later, the creation permission on the public schema is revoked by default and this exploit can only be achieved if a superuser adds a new schema in her/his own search_path and grants the CREATE privilege on that schema to untrusted users, both actions being clearly discouraged by the PostgreSQL documentation. The problem is resolved in PostgreSQL Anonymizer 3.0.1 and further versions
Affected products
- DALIBO PostgreSQL Anonymizer: from 1 before 3.0.1 — fixed in 3.0.1
How to fix
Upgrade to a fixed version: DALIBO PostgreSQL Anonymizer 3.0.1. Check the vendor advisory for mitigations.
References
- https://gitlab.com/dalibo/postgresql_anonymizer/-/blob/latest/NEWS.md
- https://gitlab.com/dalibo/postgresql_anonymizer/-/issues/616
- https://www.postgresql.org/docs/current/ddl-schemas.html#DDL-SCHEMAS-PATH
Get alerted when CVE-2026-2360 or the next vulnerability affects your stack