What’s Vulnerable › Vulnerabilities
CVE-2026-2361: Improper search_path protection in PostgreSQL Anonymizer 2.5 allows any user with create privilege to gain superuser privileges
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-11 · updated 2026-06-17
- Weakness: CWE-427
Description
PostgreSQL Anonymizer contains a vulnerability that allows a user to gain superuser privileges by creating a temporary view based on a function containing malicious code. When the anon.get_tablesample_ratio function is then called, the malicious code is executed with superuser privileges. This privilege elevation can be exploited by users having the CREATE privilege in PostgreSQL 15 and later. The risk is higher with PostgreSQL 14 or with instances upgraded from PostgreSQL 14 or a prior version because the creation permission on the public schema is granted by default. The problem is resolved in PostgreSQL Anonymizer 3.0.1 and further versions
Affected products
- DALIBO PostgreSQL Anonymizer: from 1 before 3.0.1 — fixed in 3.0.1
How to fix
Upgrade to a fixed version: DALIBO PostgreSQL Anonymizer 3.0.1. Check the vendor advisory for mitigations.
References
- https://gitlab.com/dalibo/postgresql_anonymizer/-/blob/latest/NEWS.md
- https://gitlab.com/dalibo/postgresql_anonymizer/-/issues/617
Get alerted when CVE-2026-2361 or the next vulnerability affects your stack