What’s Vulnerable › Vulnerabilities
CVE-2026-23611: GFI MailEssentials AI < 22.4 Anti-Spam IP Blocklist Description Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-19 · updated 2026-06-17
- Weakness: CWE-79
Description
GFI MailEssentials AI versions prior to 22.4 contain a stored cross-site scripting vulnerability in the IP Blocklist management page. An authenticated user can supply HTML/JavaScript in the ctl00$ContentPlaceHolder1$pv1$txtIPDescription parameter to /MailEssentials/pages/MailSecurity/ipblocklist.aspx, which is stored and later rendered in the management interface, allowing script execution in the context of a logged-in user.
Affected products
- GFI Software MailEssentials AI: before 22.4 — fixed in 22.4
How to fix
Upgrade to a fixed version: GFI Software MailEssentials AI 22.4. Check the vendor advisory for mitigations.
References
- https://gfi.ai/products-and-solutions/network-security-solutions/mailessentials/resources/documentation/product-releases
- https://www.vulncheck.com/advisories/gfi-mailessentials-ai-anti-spam-ip-blocklist-description-stored-xss
Get alerted when CVE-2026-23611 or the next vulnerability affects your stack