What’s Vulnerable › Vulnerabilities
CVE-2026-23626: Kimai Vulnerable to Authenticated Server-Side Template Injection (SSTI)
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-18 · updated 2026-06-17
- Weakness: CWE-1336
Description
Kimai is a web-based multi-user time-tracking application. Prior to version 2.46.0, Kimai's export functionality uses a Twig sandbox with an overly permissive security policy (`DefaultPolicy`) that allows arbitrary method calls on objects available in the template context. An authenticated user with export permissions can deploy a malicious Twig template that extracts sensitive information including environment variables, all user password hashes, serialized session tokens, and CSRF tokens. Version 2.46.0 patches this issue.
Affected products
- kimai: before 2.46.0 — fixed in 2.46.0
How to fix
Upgrade to a fixed version: kimai 2.46.0. Check the vendor advisory for mitigations.
References
- https://github.com/kimai/kimai/commit/6a86afb5fd79f6c1825060b87c09bd1909c2e86f
- https://github.com/kimai/kimai/pull/5757
- https://github.com/kimai/kimai/releases/tag/2.46.0
- https://github.com/kimai/kimai/security/advisories/GHSA-jg2j-2w24-54cg
Get alerted when CVE-2026-23626 or the next vulnerability affects your stack