What’s Vulnerable › Vulnerabilities

CVE-2026-23630: Docmost is vulnerable to stored Cross-Site Scripting (XSS) through Mermaid rendering

Description

Docmost is open-source collaborative wiki and documentation software. In versions 0.3.0 through 0.23.2, Mermaid code block rendering is vulnerable to stored Cross-Site Scripting (XSS). The frontend can render attacker-controlled Mermaid diagrams using mermaid.render(), then inject the returned SVG/HTML into the DOM via dangerouslySetInnerHTML without sanitization. Mermaid per-diagram %%{init}%% directives allow overriding securityLevel and enabling htmlLabels, permitting arbitrary HTML/JS execution for any viewer. This issue has been fixed in version 0.24.0.

Affected products

How to fix

Upgrade to a fixed version: docmost 0.24.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-23630 or the next vulnerability affects your stack