What’s Vulnerable › Vulnerabilities
CVE-2026-2364: CODESYS Installer TOCTOU Privilege Escalation
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-10 · updated 2026-06-17
- Weakness: CWE-367
Description
If a legitimate user confirms a self-update prompt or initiate an installation of a CODESYS Development System, a low privileged local attacker can gain elevated rights due to a TOCTOU vulnerability in the CODESYS installer.
Affected products
- CODESYS Installer: before 2.6.1.0 — fixed in 2.6.1.0
How to fix
Upgrade to a fixed version: CODESYS Installer 2.6.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-2364 or the next vulnerability affects your stack