What’s Vulnerable › Vulnerabilities
CVE-2026-23643: CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-16 · updated 2026-06-17
- Weakness: CWE-79
Description
CakePHP is a rapid development framework for PHP. The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation. This issue has been fixed in 5.2.12 and 5.3.1.
Affected products
- cakephp: from 5.2.10 before 5.2.12; 5.3.0 — fixed in 5.2.12
How to fix
Upgrade to a fixed version: cakephp 5.2.12. Check the vendor advisory for mitigations.
References
- https://bakery.cakephp.org/2026/01/14/cakephp_5212.html
- https://github.com/cakephp/cakephp/commit/c842e7f45d85696e6527d8991dd72f525ced955f
- https://github.com/cakephp/cakephp/issues/19172
- https://github.com/cakephp/cakephp/releases/tag/5.2.12
- https://github.com/cakephp/cakephp/releases/tag/5.3.1
- https://github.com/cakephp/cakephp/security/advisories/GHSA-qh8m-9qxx-53m5
Get alerted when CVE-2026-23643 or the next vulnerability affects your stack