What’s Vulnerable › Vulnerabilities
CVE-2026-23694: Aruba HiSpeed Cache < 3.0.5 CSRF in Multiple Administrative AJAX Actions
- Severity: medium (CVSS 5.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-23 · updated 2026-06-17
- Weakness: CWE-352
Description
Aruba HiSpeed Cache (aruba-hispeed-cache) WordPress plugin versions prior to 3.0.5 contain a cross-site request forgery (CSRF) vulnerability affecting multiple administrative AJAX actions. The handlers for ahsc_reset_options, ahsc_debug_status, and ahsc_enable_purge perform authentication and capability checks but do not verify a WordPress nonce for state-changing requests. An attacker can induce a logged-in administrator to visit a malicious webpage that submits forged requests to admin-ajax.php, resulting in unauthorized resetting of plugin settings, toggling of the WordPress WP_DEBUG configuration, or modification of cache purging behavior without the administrator’s intent.
Affected products
- Aruba.it Aruba HiSpeed Cache: before 3.0.5 — fixed in 3.0.5
How to fix
Upgrade to a fixed version: Aruba.it Aruba HiSpeed Cache 3.0.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-23694 or the next vulnerability affects your stack