What’s Vulnerable › Vulnerabilities

CVE-2026-2370: Improper Handling of Parameters in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 14.3 before 18.8.7, 18.9 before 18.9.3, and 18.10 before 18.10.1 affecting Jira Connect installations that could have allowed an authenticated user with minimal workspace permissions to obtain installation credentials and impersonate the GitLab app due to improper authorization checks.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.8.7, 18.9.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-2370 or the next vulnerability affects your stack