What’s Vulnerable › Vulnerabilities
CVE-2026-23753: GFI HelpDesk < 4.99.9 Stored XSS via charset Parameter
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-20 · updated 2026-10-26
- Weakness: CWE-79
Description
GFI HelpDesk before 4.99.9 contains a stored cross-site scripting vulnerability in the language management functionality where the charset POST parameter is passed directly to SWIFT_Language::Create() without HTML sanitization and subsequently rendered unsanitized by View_Language.RenderGrid(). An authenticated administrator can inject arbitrary JavaScript through the charset field when creating or editing a language, and the payload executes in the browser of any administrator viewing the Languages page.
Affected products
- GFI Software HelpDesk: before 4.99.9 — fixed in 4.99.9
How to fix
Upgrade to a fixed version: GFI Software HelpDesk 4.99.9. Check the vendor advisory for mitigations.
References
- https://gfi.ai/products-and-solutions/email-and-messaging-solutions/helpdesk/resources/product-releases
- https://www.vulncheck.com/advisories/gfi-helpdesk-stored-xss-via-charset-parameter
Get alerted when CVE-2026-23753 or the next vulnerability affects your stack