What’s Vulnerable › Vulnerabilities
CVE-2026-23756: GFI HelpDesk < 4.99.9 Stored XSS via Troubleshooter Step Subject
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-20 · updated 2026-10-26
- Weakness: CWE-79
Description
GFI HelpDesk before 4.99.9 contains a stored cross-site scripting vulnerability in the Troubleshooter module where the subject POST parameter is not sanitized in Controller_Step.InsertSubmit() and EditSubmit() before being rendered by View_Step.RenderViewSteps(). An authenticated staff member can inject arbitrary JavaScript into the step subject field, and the payload executes when any user navigates to Troubleshooter > View Troubleshooter and clicks the affected step link.
Affected products
- GFI Software HelpDesk: before 4.99.9 — fixed in 4.99.9
How to fix
Upgrade to a fixed version: GFI Software HelpDesk 4.99.9. Check the vendor advisory for mitigations.
References
- https://gfi.ai/products-and-solutions/email-and-messaging-solutions/helpdesk/resources/product-releases
- https://www.vulncheck.com/advisories/gfi-helpdesk-stored-xss-via-troubleshooter-step-subject
Get alerted when CVE-2026-23756 or the next vulnerability affects your stack