What’s Vulnerable › Vulnerabilities
CVE-2026-23757: GFI HelpDesk < 4.99.10 Stored XSS via Reports Module
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-20 · updated 2026-10-26
- Weakness: CWE-79
Description
GFI HelpDesk before 4.99.10 contains a stored cross-site scripting vulnerability in the Reports module where the title parameter is passed directly to SWIFT_Report::Create() without HTML sanitization. Attackers can inject arbitrary JavaScript into the report title field when creating or editing a report, and the payload executes when staff members view and click the affected report link in the Manage Reports interface.
Affected products
- GFI Software HelpDesk: before 4.99.10 — fixed in 4.99.10
How to fix
Upgrade to a fixed version: GFI Software HelpDesk 4.99.10. Check the vendor advisory for mitigations.
References
- https://gfi.ai/products-and-solutions/email-and-messaging-solutions/helpdesk/resources/product-releases
- https://www.vulncheck.com/advisories/gfi-helpdesk-stored-xss-via-reports-module
Get alerted when CVE-2026-23757 or the next vulnerability affects your stack