What’s Vulnerable › Vulnerabilities
CVE-2026-23795: Apache Syncope: Console XXE on Keymaster parameters
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-03 · updated 2026-06-17
- Weakness: CWE-611
Description
Improper Restriction of XML External Entity Reference vulnerability in Apache Syncope Console. An administrator with adequate entitlements to create or edit Keymaster parameters via Console can construct malicious XML text to launch an XXE attack, thereby causing sensitive data leakage occurs. This issue affects Apache Syncope: from 3.0 through 3.0.15, from 4.0 through 4.0.3. Users are recommended to upgrade to version 3.0.16 / 4.0.4, which fix this issue.
Affected products
- Apache Software Foundation Apache Syncope: from 3.0.0 before 3.0.16; from 4.0.0 before 4.0.4 — fixed in 3.0.16, 4.0.4
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Syncope 3.0.16, 4.0.4. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/mzgbdn8hzk8vr94o660njcc7w62c2pos
- http://www.openwall.com/lists/oss-security/2026/02/02/2
Get alerted when CVE-2026-23795 or the next vulnerability affects your stack