What’s Vulnerable › Vulnerabilities
CVE-2026-23821: Inconsistent input filtering allows Authenticated Command Injection in AOS-10 CLI
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-12 · updated 2026-10-26
- Weakness: CWE-78
Description
A vulnerability in the configuration processing logic of Access Points running AOS-10 could allow an authenticated remote attacker to execute system commands under certain pre-existing conditions. Successful exploitation could allow an attacker to execute arbitrary commands on the underlying operating system. Note: Access Points running AOS-8 Instant software are not affected by this vulnerability.
Affected products
- Hewlett Packard Enterprise (HPE) ArubaOS (AOS): from 6.4.0.0 through 6.5.4.24; from 8.4.0.0 before 8.10.0.0; from 8.11.0.0 before 8.12.0.7; from 10.3.0.0 before 10.4.1.11; from 10.5.0.0 before 10.7.2.3; 10.8.0.0 — fixed in 8.10.0.0, 8.12.0.7, 10.4.1.11, 10.7.2.3
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) ArubaOS (AOS) 8.10.0.0, 8.12.0.7, 10.4.1.11, 10.7.2.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-23821 or the next vulnerability affects your stack