What’s Vulnerable › Vulnerabilities
CVE-2026-23836: HotCRP vulnerable to remote code execution through formulas
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-19 · updated 2026-06-17
- Weakness: CWE-20
Description
HotCRP is conference review software. A problem introduced in April 2024 in version 3.1 led to inadequately sanitized code generation for HotCRP formulas which allowed users to trigger the execution of arbitrary PHP code. The problem is patched in release version 3.2.
Affected products
- kohler hotcrp: from 3.0 before 3.2 — fixed in 3.2
How to fix
Upgrade to a fixed version: kohler hotcrp 3.2. Check the vendor advisory for mitigations.
References
- https://github.com/kohler/hotcrp/commit/4674fcfbb76511072a1145dad620756fc1d4b4e9
- https://github.com/kohler/hotcrp/commit/bfc7e0db15df6ed6d544a639020d2ce05a5f0834
- https://github.com/kohler/hotcrp/security/advisories/GHSA-hpqh-j6qx-x57h
Get alerted when CVE-2026-23836 or the next vulnerability affects your stack