What’s Vulnerable › Vulnerabilities
CVE-2026-23864
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-26 · updated 2026-07-15
- Weakness: CWE-400
Description
Multiple denial of service vulnerabilities exist in React Server Components, affecting the following packages: react-server-dom-parcel, react-server-dom-turbopack, react-server-dom-webpack. The vulnerabilities are triggered by sending specially crafted HTTP requests to Server Function endpoints, and could lead to server crashes, out-of-memory exceptions or excessive CPU usage; depending on the vulnerable code path being exercised, the application configuration and application code. Strongly consider upgrading to the latest package versions to reduce risk and prevent availability issues in applications using React Server Components.
Affected products
- React: from 19.0.0 before 19.0.4; from 19.1.0 before 19.1.5; from 19.2.0 before 19.2.4 — fixed in 19.0.4, 19.1.5, 19.2.4
How to fix
Upgrade to a fixed version: React 19.0.4, 19.1.5, 19.2.4. Check the vendor advisory for mitigations.
References
- https://www.facebook.com/security/advisories/cve-2026-23864
- https://access.redhat.com/errata/RHSA-2026:13571
- https://access.redhat.com/errata/RHSA-2026:34608
- https://access.redhat.com/security/cve/CVE-2026-23864
- https://bugzilla.redhat.com/show_bug.cgi?id=2433059
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-23864.json
Get alerted when CVE-2026-23864 or the next vulnerability affects your stack