What’s Vulnerable › Vulnerabilities
CVE-2026-23881: Kyverno Denial of Service via Context Variable Amplification in Policy Engine
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-27 · updated 2026-06-17
- Weakness: CWE-770
Description
Kyverno is a policy engine designed for cloud native platform engineering teams. Versions prior to 1.16.3 and 1.15.3 have unbounded memory consumption in Kyverno's policy engine that allows users with policy creation privileges to cause denial of service by crafting policies that exponentially amplify string data through context variables. Versions 1.16.3 and 1.15.3 contain a patch for the vulnerability.
Affected products
- kyverno: before 1.15.3; from 1.16.0 before 1.16.3 — fixed in 1.15.3, 1.16.3
How to fix
Upgrade to a fixed version: kyverno 1.15.3, 1.16.3. Check the vendor advisory for mitigations.
References
- https://github.com/kyverno/kyverno/commit/7a651be3a8c78dcabfbf4178b8d89026bf3b850f
- https://github.com/kyverno/kyverno/commit/f5617f60920568a301740485472bf704892175b7
- https://github.com/kyverno/kyverno/security/advisories/GHSA-r2rj-wwm5-x6mq
Get alerted when CVE-2026-23881 or the next vulnerability affects your stack