What’s Vulnerable › Vulnerabilities
CVE-2026-23890: pnpm scoped bin name Path Traversal allows arbitrary file creation outside node_modules/.bin
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-26 · updated 2026-06-17
- Weakness: CWE-23
Description
pnpm is a package manager. Prior to version 10.28.1, a path traversal vulnerability in pnpm's bin linking allows malicious npm packages to create executable shims or symlinks outside of `node_modules/.bin`. Bin names starting with `@` bypass validation, and after scope normalization, path traversal sequences like `../../` remain intact. This issue affects all pnpm users who install npm packages and CI/CD pipelines using pnpm. It can lead to overwriting config files, scripts, or other sensitive files. Version 10.28.1 contains a patch.
Affected products
- pnpm: before 10.28.1 — fixed in 10.28.1
How to fix
Upgrade to a fixed version: pnpm 10.28.1. Check the vendor advisory for mitigations.
References
- https://github.com/pnpm/pnpm/commit/8afbb1598445d37985d91fda18abb4795ae5062d
- https://github.com/pnpm/pnpm/releases/tag/v10.28.1
- https://github.com/pnpm/pnpm/security/advisories/GHSA-xpqm-wm3m-f34h
Get alerted when CVE-2026-23890 or the next vulnerability affects your stack