What’s Vulnerable › Vulnerabilities
CVE-2026-23891: Decidim has a Cross-site scripting (XSS) vulnerability via user name field
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-13 · updated 2026-06-17
- Weakness: CWE-79
Description
Decidim is a participatory democracy framework. In versions below 0.30.5 and 0.31.0.rc1 through 0.31.0, a stored code execution vulnerability in the user name field allows a low-privileged attacker to execute arbitrary code in the context of any user who passively visits a comment page, resulting in high confidentiality and integrity impact across security boundaries. This issue has been fixed in versions 0.30.5 and 0.31.1.
Affected products
- decidim: before 0.30.5; from 0.31.0 before 0.31.1 — fixed in 0.30.5, 0.31.1
How to fix
Upgrade to a fixed version: decidim 0.30.5, 0.31.1. Check the vendor advisory for mitigations.
References
- https://github.com/decidim/decidim/releases/tag/v0.30.5
- https://github.com/decidim/decidim/releases/tag/v0.31.1
- https://github.com/decidim/decidim/security/advisories/GHSA-fc46-r95f-hq7g
Get alerted when CVE-2026-23891 or the next vulnerability affects your stack