What’s Vulnerable › Vulnerabilities

CVE-2026-23897: Apollo Server is vulnerable to denial of service with `startStandaloneServer`

Description

Apollo Server is an open-source, spec-compliant GraphQL server that's compatible with any GraphQL client, including Apollo Client. In versions from 2.0.0 to 3.13.0, 4.2.0 to before 4.13.0, and 5.0.0 to before 5.4.0, the default configuration of startStandaloneServer from @apollo/server/standalone is vulnerable to denial of service (DoS) attacks through specially crafted request bodies with exotic character set encodings. This issue does not affect users that use @apollo/server as a dependency for integration packages, like @as-integrations/express5 or @as-integrations/next, only direct usage of startStandaloneServer.

Affected products

How to fix

Upgrade to a fixed version: apollographql apollo-server 4.13.0, 5.4.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-23897 or the next vulnerability affects your stack